// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)System\.out\.println\(\"[^\":]*\s(?:job|jb?c)\s[^\":]*:[^\"]*\"[^)]*\);"#).unwrap();
let string = "System.out.println(\"my job code is: \" var.jobcode);
System.out.println(\"my jc is: \" var.jc);
System.out.println(\"my jbc is: \" var.jbc);
System.out.println (\"component printout: item\"); System.out.println (\"\"); <td style=\"word-break: break-all;word-wrap:break-word;font-size:12px;\" class=\"FONTSTYLE\" align=\"left\">Job Codes</td><td style=\"word-break: break-all;word-wrap:break-word;font-size:12px;\" class=\"FONTSTYLE\" align=\"left\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}