$re = '/System\.out\.println\(\"[^\":]*\s(?:job|jb?c)\s[^\":]*:[^\"]*\"[^)]*\);/m';
$str = 'System.out.println("my job code is: " var.jobcode);
System.out.println("my jc is: " var.jc);
System.out.println("my jbc is: " var.jbc);
System.out.println ("component printout: item"); System.out.println (""); <td style="word-break: break-all;word-wrap:break-word;font-size:12px;" class="FONTSTYLE" align="left">Job Codes</td><td style="word-break: break-all;word-wrap:break-word;font-size:12px;" class="FONTSTYLE" align="left">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);