package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(label\s\d{1,4}\sstart(\s*explanation)(.*?)up\sup\s*exit)`)
var str = `label 123 start
int
some other random text
exit
exit
label 576 start
int
some other random text
exit
exit
label 888 start
explanation jgfjgjgj
some random text
exit
up up
exit
label 902 start
explanation jgfjgjgj
some random text
exit
up up
exit
label 456 start
explanation jgfjgjgj
some random text
exit
up up
exit`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}