$re = '/(label\s\d{1,4}\sstart(\s*explanation)(.*?)up\sup\s*exit)/s';
$str = 'label 123 start
int
some other random text
exit
exit
label 576 start
int
some other random text
exit
exit
label 888 start
explanation jgfjgjgj
some random text
exit
up up
exit
label 902 start
explanation jgfjgjgj
some random text
exit
up up
exit
label 456 start
explanation jgfjgjgj
some random text
exit
up up
exit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);