use strict;
my $str = 'label 123 start
int
some other random text
exit
exit
label 576 start
int
some other random text
exit
exit
label 888 start
explanation jgfjgjgj
some random text
exit
up up
exit
label 902 start
explanation jgfjgjgj
some random text
exit
up up
exit
label 456 start
explanation jgfjgjgj
some random text
exit
up up
exit';
my $regex = qr/(label\s\d{1,4}\sstart(\s*explanation)(.*?)up\sup\s*exit)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}