# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(label\s\d{1,4}\sstart(\s*explanation)(.*?)up\sup\s*exit)"
test_str = ("label 123 start\n"
" int\n"
" some other random text\n"
" exit\n"
"exit\n"
"label 576 start\n"
" int\n"
" some other random text\n"
" exit\n"
"exit\n"
"label 888 start\n"
" explanation jgfjgjgj\n"
" some random text \n"
" exit\n"
"up up\n"
"exit\n"
"label 902 start\n"
" explanation jgfjgjgj\n"
" some random text \n"
" exit\n"
"up up\n"
"exit\n"
"label 456 start\n"
" explanation jgfjgjgj\n"
" some random text \n"
" exit\n"
"up up\n"
"exit")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.