using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+(?:\.[A-Za-z]+)?$";
string input = @".ilikestack@gmail.com
ilikestack@gmail.com_
ilikestack@gmail.com
ilike.stack@gmail.co.uk
i@1.co
i@1.c
i@1.c.a
i@1.1
i@abcabca.abcabcaabcabcaabcabca.abcabca";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}