import re
regex = re.compile(r"^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+(?:\.[A-Za-z]+)?$", flags=re.MULTILINE)
test_str = (".ilikestack@gmail.com\n"
"ilikestack@gmail.com_\n"
"ilikestack@gmail.com\n"
"ilike.stack@gmail.co.uk\n"
"i@1.co\n"
"i@1.c\n"
"i@1.c.a\n"
"i@1.1\n"
"i@abcabca.abcabcaabcabcaabcabca.abcabca")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")