const regex = /^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+(?:\.[A-Za-z]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\\.[A-Za-z]+(?:\\.[A-Za-z]+)?$', 'gm')
const str = `.ilikestack@gmail.com
ilikestack@gmail.com_
ilikestack@gmail.com
ilike.stack@gmail.co.uk
i@1.co
i@1.c
i@1.c.a
i@1.1
i@abcabca.abcabcaabcabcaabcabca.abcabca`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}