$re = '/^[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+(?:\.[A-Za-z]+)?$/m';
$str = '.ilikestack@gmail.com
ilikestack@gmail.com_
ilikestack@gmail.com
ilike.stack@gmail.co.uk
i@1.co
i@1.c
i@1.c.a
i@1.1
i@abcabca.abcabcaabcabcaabcabca.abcabca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);