#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\:([0-9]{1,4}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))?$"
Local $sString = "0.0.0.0" & @CRLF & _
"0.0.0.0:1" & @CRLF & _
"255.255.255.255:1" & @CRLF & _
"192.168.54.25" & @CRLF & _
"192.168.54.25:42168" & @CRLF & _
"192.168.54.25:65535" & @CRLF & _
"192.168.54.25:65536" & @CRLF & _
"" & @CRLF & _
"000.0000.00.00 " & @CRLF & _
"192.168.1.1:80" & @CRLF & _
"0.0.0.0:123" & @CRLF & _
"912.456.123.123" & @CRLF & _
"123.456.789.123" & @CRLF & _
"255.255.255.255:65536" & @CRLF & _
"255.255.255.255:65535" & @CRLF & _
"256.256.256.256:80"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")