import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\:([0-9]{1,4}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))?$";
final String string = "0.0.0.0\n"
+ "0.0.0.0:1\n"
+ "255.255.255.255:1\n"
+ "192.168.54.25\n"
+ "192.168.54.25:42168\n"
+ "192.168.54.25:65535\n"
+ "192.168.54.25:65536\n\n"
+ "000.0000.00.00 \n"
+ "192.168.1.1:80\n"
+ "0.0.0.0:123\n"
+ "912.456.123.123\n"
+ "123.456.789.123\n"
+ "255.255.255.255:65536\n"
+ "255.255.255.255:65535\n"
+ "256.256.256.256:80";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}