// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\:([0-9]{1,4}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))?$").unwrap();
let string = "0.0.0.0
0.0.0.0:1
255.255.255.255:1
192.168.54.25
192.168.54.25:42168
192.168.54.25:65535
192.168.54.25:65536
000.0000.00.00
192.168.1.1:80
0.0.0.0:123
912.456.123.123
123.456.789.123
255.255.255.255:65536
255.255.255.255:65535
256.256.256.256:80";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}