$re = '/^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\:([0-9]{1,4}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))?$/m';
$str = '0.0.0.0
0.0.0.0:1
255.255.255.255:1
192.168.54.25
192.168.54.25:42168
192.168.54.25:65535
192.168.54.25:65536
000.0000.00.00
192.168.1.1:80
0.0.0.0:123
912.456.123.123
123.456.789.123
255.255.255.255:65536
255.255.255.255:65535
256.256.256.256:80';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);