#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\p{Zs}\t]*Application Name:[\p{Zs}\t]*(.+)\r?\n[\p{Zs}\t]*Application Id:.*\r?\n[\p{Zs}\t]*Secret Key:[\p{Zs}\t]*(.+)"
Local $sString = "Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW1" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW2" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
" " & @CRLF & _
" Application Name: XYXZW3" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
" Secret Key: XYZ86JBHHSD" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW4" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
" Secret Key: XYZ86JBHHSD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")