import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\p{Zs}\\t]*Application Name:[\\p{Zs}\\t]*(.+)\\r?\\n[\\p{Zs}\\t]*Application Id:.*\\r?\\n[\\p{Zs}\\t]*Secret Key:[\\p{Zs}\\t]*(.+)";
final String string = "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW1\n"
+ " Application Id: XYZ353WERX\n\n"
+ "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW2\n"
+ " Application Id: XYZ353WERX\n\n"
+ "Application Details for the XYZ application:\n"
+ " =========================================================\n"
+ " \n"
+ " Application Name: XYXZW3\n"
+ " Application Id: XYZ353WERX\n"
+ " Secret Key: XYZ86JBHHSD\n\n"
+ "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW4\n"
+ " Application Id: XYZ353WERX\n"
+ " Secret Key: XYZ86JBHHSD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}