re = /^[\p{Zs}\t]*Application Name:[\p{Zs}\t]*(.+)\r?\n[\p{Zs}\t]*Application Id:.*\r?\n[\p{Zs}\t]*Secret Key:[\p{Zs}\t]*(.+)/m
str = 'Application Details for the XYZ application:
=========================================================
Application Name: XYXZW1
Application Id: XYZ353WERX
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW2
Application Id: XYZ353WERX
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW3
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW4
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end