# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\p{Zs}\t]*Application Name:[\p{Zs}\t]*(.+)\r?\n[\p{Zs}\t]*Application Id:.*\r?\n[\p{Zs}\t]*Secret Key:[\p{Zs}\t]*(.+)"
test_str = ("Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW1\n"
" Application Id: XYZ353WERX\n\n"
"Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW2\n"
" Application Id: XYZ353WERX\n\n"
"Application Details for the XYZ application:\n"
" =========================================================\n"
" \n"
" Application Name: XYXZW3\n"
" Application Id: XYZ353WERX\n"
" Secret Key: XYZ86JBHHSD\n\n"
"Application Details for the XYZ application:\n"
" =========================================================\n\n"
" Application Name: XYXZW4\n"
" Application Id: XYZ353WERX\n"
" Secret Key: XYZ86JBHHSD")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.