#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\d)\S+$"
Local $sString = "123FGA" & @CRLF & _
"dsfsdfggfgfg4" & @CRLF & _
"2f" & @CRLF & _
"g6" & @CRLF & _
"dsfsdfg3gfgfg4a" & @CRLF & _
"" & @CRLF & _
"aaa 5aaa fdfdffff" & @CRLF & _
"FGA" & @CRLF & _
"123434567 FGA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")