using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)\S+$";
string input = @"123FGA
dsfsdfggfgfg4
2f
g6
dsfsdfg3gfgfg4a
aaa 5aaa fdfdffff
FGA
123434567 FGA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}