$re = '/^(?=.*\d)\S+$/m';
$str = '123FGA
dsfsdfggfgfg4
2f
g6
dsfsdfg3gfgfg4a
aaa 5aaa fdfdffff
FGA
123434567 FGA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);