import re
regex = re.compile(r"^(?=.*\d)\S+$", flags=re.MULTILINE)
test_str = ("123FGA\n"
"dsfsdfggfgfg4\n"
"2f\n"
"g6\n"
"dsfsdfg3gfgfg4a\n\n"
"aaa 5aaa fdfdffff\n"
"FGA\n"
"123434567 FGA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")