use strict;
my $str = '
const test = {
\'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center\':
true,
\'bg-blue-1/10 text-blue-1 border-blue-1\': true,
};
className={classNames({
\'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center\':
true,
\'bg-blue-1/10 text-blue-1 border-blue-1\': open,
})}
>
';
my $regex = qr/(?<=\{classNames.*\(\{(?:.|\n)*').*(?=')/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}