# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\{classNames.*\(\{(?:.|\n)*').*(?=')"
test_str = ("\n"
" const test = {\n"
" 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':\n"
" true,\n"
" 'bg-blue-1/10 text-blue-1 border-blue-1': true,\n"
" };\n\n"
" className={classNames({\n"
" 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':\n"
" true,\n"
" 'bg-blue-1/10 text-blue-1 border-blue-1': open,\n"
" })}\n"
" >\n"
" \n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.