re = /(?<=\{classNames.*\(\{(?:.|\n)*').*(?=')/
str = '
const test = {
\'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center\':
true,
\'bg-blue-1/10 text-blue-1 border-blue-1\': true,
};
className={classNames({
\'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center\':
true,
\'bg-blue-1/10 text-blue-1 border-blue-1\': open,
})}
>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end