using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"total-review-count[^>]*>(\d+(?:,\d+)*)グローバルレーティング";
string input = @"<span data-hook=""total-review-count"" class=""a-size-base a-color-secondary"">1,008グローバルレーティング</span>
<span data-hook=""total-review-count"" class=""a-size-base a-color-secondary"">1008グローバルレーティング</span>
<span data-hook=""total-review-count"" class=""a-size-base a-color-secondary"">1,000,008グローバルレーティング</span>
<span data-hook=""total-review-count"" class=""a-size-base a-color-secondary"">1,000,000,008グローバルレーティング</span>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}