# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"total-review-count[^>]*>(\d+(?:,\d+)*)グローバルレーティング"
test_str = ("<span data-hook=\"total-review-count\" class=\"a-size-base a-color-secondary\">1,008グローバルレーティング</span>\n\n"
"<span data-hook=\"total-review-count\" class=\"a-size-base a-color-secondary\">1008グローバルレーティング</span>\n"
"<span data-hook=\"total-review-count\" class=\"a-size-base a-color-secondary\">1,000,008グローバルレーティング</span>\n\n\n"
"<span data-hook=\"total-review-count\" class=\"a-size-base a-color-secondary\">1,000,000,008グローバルレーティング</span>")
matches = re.finditer(regex, test_str, re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.