$re = '/total-review-count[^>]*>(\d+(?:,\d+)*)グローバルレーティング/sm';
$str = '<span data-hook="total-review-count" class="a-size-base a-color-secondary">1,008グローバルレーティング</span>
<span data-hook="total-review-count" class="a-size-base a-color-secondary">1008グローバルレーティング</span>
<span data-hook="total-review-count" class="a-size-base a-color-secondary">1,000,008グローバルレーティング</span>
<span data-hook="total-review-count" class="a-size-base a-color-secondary">1,000,000,008グローバルレーティング</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);