package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)total-review-count[^>]*>(\d+(?:,\d+)*)グローバルレーティング`)
var str = `<span data-hook="total-review-count" class="a-size-base a-color-secondary">1,008グローバルレーティング</span>
<span data-hook="total-review-count" class="a-size-base a-color-secondary">1008グローバルレーティング</span>
<span data-hook="total-review-count" class="a-size-base a-color-secondary">1,000,008グローバルレーティング</span>
<span data-hook="total-review-count" class="a-size-base a-color-secondary">1,000,000,008グローバルレーティング</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}