using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"menupoint\/[^\/]+$";
string input = @"aaaaaa/aaa/menupoint/example
aaaaaa/aaa/menupoint/example/example
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}