$re = '/menupoint\/[^\/]+$/';
$str = 'aaaaaa/aaa/menupoint/example
aaaaaa/aaa/menupoint/example/example
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);