re = /menupoint\/[^\/]+$/
str = 'aaaaaa/aaa/menupoint/example
aaaaaa/aaa/menupoint/example/example
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end