import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s]{0,}@([\\w]+)[ ]{1,}([\\w\\d]+)[ ]{0,}\\{.+?(?=\\})";
final String string = "@component helloWorld {\n"
+ " background-color: red;\n"
+ " padding: 1rem;\n\n"
+ " @modifier red {\n"
+ " color: green;\n"
+ " }\n"
+ "}\n\n"
+ "bac";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}