$re = '/[\s]{0,}@([\w]+)[ ]{1,}([\w\d]+)[ ]{0,}{.+?(?=})/s';
$str = '@component helloWorld {
background-color: red;
padding: 1rem;
@modifier red {
color: green;
}
}
bac';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);