const regex = /[\s]{0,}@([\w]+)[ ]{1,}([\w\d]+)[ ]{0,}{.+?(?=})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s]{0,}@([\\w]+)[ ]{1,}([\\w\\d]+)[ ]{0,}{.+?(?=})', 'gs')
const str = `@component helloWorld {
background-color: red;
padding: 1rem;
@modifier red {
color: green;
}
}
bac`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}