using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\d{3}\)[ ]?\d{3}[-]?\d{4}";
string input = @"(564) 332-9088
336-678-8999
(336) 678-8909
(336)-678-8999";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}