re = /\(\d{3}\)[ ]?\d{3}[-]?\d{4}/
str = '(564) 332-9088
336-678-8999
(336) 678-8909
(336)-678-8999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end