package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\d{3}\)[ ]?\d{3}[-]?\d{4}`)
var str = `(564) 332-9088
336-678-8999
(336) 678-8909
(336)-678-8999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}