$re = '/\(\d{3}\)[ ]?\d{3}[-]?\d{4}/';
$str = '(564) 332-9088
336-678-8999
(336) 678-8909
(336)-678-8999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);