using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*sources\/(.*)\/.*\?(.*)\/?";
string input = @"http://localhost:7776/__api/sources/KEK/content?a__contains=xyu";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}