$re = '/.*sources\/(.*)\/.*\?(.*)\/?/m';
$str = 'http://localhost:7776/__api/sources/KEK/content?a__contains=xyu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);