package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(url\s*\([^()]+\))|(@import[^;]+;)`)
var str = `@import "//static001.geekbang.org/static/infoq/www/css/app.0d41a85d7b732aac5d44bdf04a8b642c.css";
@font-face {
font-family: layui-icon;
src: url(http://foo.com/font/iconfont.eot?v=230-rc1);
src: url(http://foo.com/font/iconfont.eot?v=230-rc1#iefix) format('embedded-opentype'),url(//foo.com/font/iconfont.svg?v=230-rc1#iconfont)
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}