// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(url\s*\([^()]+\))|(@import[^;]+;)").unwrap();
let string = "@import \"//static001.geekbang.org/static/infoq/www/css/app.0d41a85d7b732aac5d44bdf04a8b642c.css\";
@font-face {
font-family: layui-icon;
src: url(http://foo.com/font/iconfont.eot?v=230-rc1);
src: url(http://foo.com/font/iconfont.eot?v=230-rc1#iefix) format('embedded-opentype'),url(//foo.com/font/iconfont.svg?v=230-rc1#iconfont)
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}