import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(url\\s*\\([^()]+\\))|(@import[^;]+;)";
final String string = "@import \"//static001.geekbang.org/static/infoq/www/css/app.0d41a85d7b732aac5d44bdf04a8b642c.css\";\n\n"
+ "@font-face { \n"
+ " font-family: layui-icon;\n"
+ " src: url(http://foo.com/font/iconfont.eot?v=230-rc1);\n"
+ " src: url(http://foo.com/font/iconfont.eot?v=230-rc1#iefix) format('embedded-opentype'),url(//foo.com/font/iconfont.svg?v=230-rc1#iconfont)\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}