const regex = /(url\s*\([^()]+\))|(@import[^;]+;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(url\\s*\\([^()]+\\))|(@import[^;]+;)', 'gm')
const str = `@import "//static001.geekbang.org/static/infoq/www/css/app.0d41a85d7b732aac5d44bdf04a8b642c.css";
@font-face {
font-family: layui-icon;
src: url(http://foo.com/font/iconfont.eot?v=230-rc1);
src: url(http://foo.com/font/iconfont.eot?v=230-rc1#iefix) format('embedded-opentype'),url(//foo.com/font/iconfont.svg?v=230-rc1#iconfont)
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}