#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:(?:192\.168|172(?:\.(?:1[789]|2\d|3[01])))(?:\.\d{1,3}){2}|10(?:\.\d{1,3}){3})\b"
Local $sString = "172.17.255.255" & @CRLF & _
"172.31.1.123" & @CRLF & _
"172.16.1.123" & @CRLF & _
"192.168.0.1" & @CRLF & _
"" & @CRLF & _
"172.16.1.1" & @CRLF & _
"10.0.0.110"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")