import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:192\\.168|172(?:\\.(?:1[789]|2\\d|3[01])))(?:\\.\\d{1,3}){2}|10(?:\\.\\d{1,3}){3})\\b";
final String string = "172.17.255.255\n"
+ "172.31.1.123\n"
+ "172.16.1.123\n"
+ "192.168.0.1\n\n"
+ "172.16.1.1\n"
+ "10.0.0.110";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}