re = /\b(?:(?:192\.168|172(?:\.(?:1[789]|2\d|3[01])))(?:\.\d{1,3}){2}|10(?:\.\d{1,3}){3})\b/m
str = '172.17.255.255
172.31.1.123
172.16.1.123
192.168.0.1
172.16.1.1
10.0.0.110'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end