#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\d{4}-){3}\d{4}|\d{16}"
Local $sString = "5123-4567-8912-3456" & @CRLF & _
"61234-567-8912-3456" & @CRLF & _
"4123356789123456" & @CRLF & _
"5133-3367-8912-3456" & @CRLF & _
"6124-56378912-3456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")