package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d{4}-){3}\d{4}|\d{16}`)
var str = `5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456
6124-56378912-3456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}